Interruption to Broadcast email reporting statistics
Incident Report for Jilt
Resolved
Broadcast email reports and statistics are working and up to date
Posted Jan 10, 2020 - 12:35 EST
Investigating
We are currently investigating this issue.
Posted Jan 10, 2020 - 09:30 EST
This incident affected: Application.