Planned Maintenance
Incident Report for Jilt
Resolved
We've completed our planned maintenance.
Posted 26 days ago. Jan 24, 2018 - 06:40 EST
Identified
We're undergoing a brief period of planned maintenance to make improvements to the Jilt application and API. We'll be back shortly!
Posted 26 days ago. Jan 24, 2018 - 06:36 EST