Planned Maintenance
Incident Report for Jilt
Resolved
We've completed our planned maintenance.
Posted almost 2 years ago. Jan 16, 2017 - 16:23 EST
Identified
We're undergoing a brief period of planned maintenance to make improvements to the Jilt application and API. We'll be back shortly!
Posted almost 2 years ago. Jan 16, 2017 - 16:18 EST