Planned Maintenance
Incident Report for Jilt
Resolved
We've completed our planned maintenance.
Posted over 1 year ago. Dec 20, 2016 - 23:45 EST
Identified
We're undergoing a brief period of planned maintenance to make improvements to the Jilt application and API. We'll be back shortly!
Posted over 1 year ago. Dec 20, 2016 - 23:35 EST