Planned Maintenance
Incident Report for Jilt
Resolved
We've completed our planned maintenance.
Posted 9 months ago. Jan 12, 2018 - 11:41 EST
Identified
We're undergoing a brief period of planned maintenance to make improvements to the Jilt application and API. We'll be back at full speed shortly!
Posted 9 months ago. Jan 12, 2018 - 09:18 EST