Planned Maintenance
Incident Report for Jilt
Resolved
We've completed our planned maintenance.
Posted about 1 year ago. Jan 26, 2017 - 15:45 EST
Identified
We're undergoing a brief period of planned maintenance to make improvements to the Jilt application and API. We'll be back shortly!
Posted about 1 year ago. Jan 26, 2017 - 15:37 EST