Planned Maintenance
Incident Report for Jilt
Resolved
We've completed our planned maintenance.
Posted 6 months ago. Jan 19, 2018 - 12:32 EST
Update
We're still undergoing a brief period of planned maintenance, we'll keep you posted.
Posted 6 months ago. Jan 19, 2018 - 11:30 EST
Identified
We're undergoing a brief period of planned maintenance to make improvements to the Jilt application and API. We'll be back at full speed shortly!
Posted 6 months ago. Jan 19, 2018 - 10:56 EST